How To Fix The Missing Thumbnail Issue, When Sharing WordPress Posts On Facebook

Many bloggers are experiencing issues with their post thumbnails, when sharing WordPress posts on Facebook. Either there is no thumbnail attached to the Facebook post at all or the wrong image is used. Since a Facebook post without images does not look very attractive in most cases, I collected some helpful tips to fix the missing thumbnail issue.

The Facebook Thumb Fixer Plugin

Luckily there is a WordPress plugin for about any problem or issue you can think of. So if you install the Facebook Thumb Fixer plugin, the Open Graph Meta Data Facebook needs to share your posts data, will be added to all your WordPress posts and pages automatically and you should not have any issues with missing thumbnail images any longer.

Under Settings → General you can also set a general Object Type for your website and set a default website image that will be used, if you share a page or post of your website on Facebook that does not have any images. The default image dimensions should be 1200×630 or 600×315 pixels.

With the plugin you can also set an individual post Object Type using the Object Type box in your posts admin area.

Add Open Graph Data via The WordPress SEO Plugin By Yoast

If you already use the SEO plugin “WordPress SEO by Yoast”, you can also set your default thumbnail image via the plugin under SEO → Social → Facebook. In the same setting you can also choose to include the Open Meta data automatically.

In case you just want to share your posts on Facebook yourself, you can also include the URL of a post without the http//www. bzw. http// at the beginning. This way your thumbnail should be included in the Facebook post, if your post has images. If your post does not have any images, you could upload an image directly in Facebook via the “Image Upload” button.

I hope you find these little tips helpful and you will have no further difficulties to include beautiful thumbnail images, when sharing WordPress posts on Facebook. If you have any further questions or advice, please write me a comment below!

  1. Ankush Ransiwal

    The problem is occurring while sharing the blog posts on the Facebook. I tired yoast seo and everything i could possibly do and i managed to get the space for the picture but there is just this blank white space coming above the link instead of thumbnail featured image. help me, I’m stuck on this for past week.

Leave a Reply

Your email address will not be published. Required fields are marked *